Maximum PC

It is currently Mon Apr 27, 2015 6:27 am

All times are UTC - 8 hours

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Razer Megalodon problem after firmware update.
PostPosted: Sun Jun 02, 2013 10:30 pm 

Joined: Fri Sep 17, 2010 12:36 am
Posts: 1
After updating my Megalodon firmware, for no reason other than an update was available, I've started having problems while running certain programs/games.
In particular my problems seem to happen at certain intervals while running Ventrilo, TF2 and I had the problem when I played Starcraft 2. Oddly, none of the MMOs or other games I spend much more time in have a problem unless I also happen to be running Vent in the background.

The problem is this: at no particular times, seems randomly, normal sounds will cut out and I'll just have a migraine-inducing endless beep in my ears. I'll have to re-plug the headset to make it stop and usually change and then revert my audio settings in-game to bring the levels back in line. Sometimes I'll be fine for the rest of my gaming session, other times I'm not.

I assumed the problem is being caused by the firmware update as I never had the problem before it. I had moved to Win8 and updated everything else plenty of times before with no issues. Though, I don't know if I can rollback the firmware. I was skeptical that the issue would be that my headset was just ready to give up the ghost since only certain programs seem to illicit the problem.

I've updated everything I can possibly think of. I've tried removing and reinstalling the programs that have issues. I can't seem to replicate the problems with the headset on other PCs. My rig is pretty out of date, granted, but upgrading isn't possible right now. I could get another headset but, honestly, I really like the Megolodon set I have, other than this recent issue, of course, and I'm concerned that if it is a compatibility issue that if I just get another pair the problem will persist if it's not the headset themselves.

Though a MaxPC reader, embarrassingly I'm inexperienced with tinkering under the hood of my OS in even simple areas like Device Manager. Through Google I couldn't seem to find any solutions to my problem so I'm posting here with hopes that someone could point me in some direction that could help me further exhaust my options and hopefully find a fix before I have to result in spending money just to make gaming tolerable again. Thanks in advance for any responses.

i7 950
Asus P6T Deluxe v2
GTX 670

 Post subject: Re: Razer Megalodon problem after firmware update.
PostPosted: Mon Jun 03, 2013 11:51 am 
[Team Member]
[Team Member]

Joined: Sat Jun 26, 2004 4:31 am
Posts: 11142
Location: Home Sweet Home
Good lesson learned here! If it works don't fix it!

I would go to their website and find out if you can roll back the firmware to the earlier version, as that one worked. I hope so, sometimes you are stuck with the bugs that are in the newer version and can't roll back.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours

Who is online

Users browsing this forum: No registered users and 12 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

© 2014 Future US, Inc. All rights reserved.