Quantcast

Maximum PC

It is currently Wed Sep 17, 2014 6:01 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: HD7970 driver install problem
PostPosted: Mon Dec 24, 2012 4:06 pm 
Million Club - 20 Plus
Million Club - 20 Plus
User avatar

Joined: Sun Sep 26, 2004 9:26 am
Posts: 4739
Location: Dixon Springs, TN
Posting this for a friend. It's got me stumped.
He installed a Gigabyte HD7970 on an ASRock Z68 Extreme4 Gen3 mobo.
CPU: Intel 2600K <-corrected
Memory: GSkill Ripjaws 8 GB
OS: Win 8 64 bit
PSU: Silverstone Strider 1000W

He uninstalled the old nvidia drivers, shut down, removed the old video card. Installed the HD7970. Restarted his computer. After the boot to windows he gets a black screen. Tired several times to no change.
You can get video output if you boot into safe mode. Tried to install drivers in safe mode.
The driver install starts and gets up to the choice of Express or Custom. It doesn't matter which one you choose the same thing happens. It errors out with this message: Failed to load detection driver.
Tried drivers form Gigabyte and AMD. Same thing.
In device manager under display adapters it shows the HD7970.
Under Monitors there is a yellow triangle with an exclamation mark in it. I'm not sure if this is like this because of being in safe mode. But I'm hoping it is.
No other areas of concern in Device Manager.
Anyone have ideas I can pass on to him?


Last edited by dedgar on Mon Dec 24, 2012 5:18 pm, edited 1 time in total.

Top
  Profile  
 
 Post subject: Re: HD7970 driver install problem
PostPosted: Mon Dec 24, 2012 4:20 pm 
Willamette
Willamette

Joined: Thu Aug 12, 2004 9:04 am
Posts: 1035
How did he uninstall the old nvidia drivers? Did he use DriverSweeper? If not, I suggest he download and run it to search for any leftover nvidia driver entries in the registry. As for the exclamation mark on the Monitor in Safe Mode, try right-clicking on the device in the Device Manager, and left-clicking the Properties option in the right-click menu and checking the Driver tab in the Properties window.


Top
  Profile  
 
 Post subject: Re: HD7970 driver install problem
PostPosted: Mon Dec 24, 2012 4:47 pm 
Million Club - 20 Plus
Million Club - 20 Plus
User avatar

Joined: Sun Sep 26, 2004 9:26 am
Posts: 4739
Location: Dixon Springs, TN
Called and asked about driver sweeper and monitor properties.
Driver sweeper wasn't used. But he gave it a try with the same results and the restart.
Monitor properties, Driver is the correct/most recent.


Top
  Profile  
 
 Post subject: Re: HD7970 driver install problem
PostPosted: Mon Dec 24, 2012 5:32 pm 
Willamette
Willamette

Joined: Thu Aug 12, 2004 9:04 am
Posts: 1035
What monitor does your friend have on this system?


Top
  Profile  
 
 Post subject: Re: HD7970 driver install problem
PostPosted: Mon Dec 24, 2012 5:56 pm 
Million Club - 20 Plus
Million Club - 20 Plus
User avatar

Joined: Sun Sep 26, 2004 9:26 am
Posts: 4739
Location: Dixon Springs, TN
Monitor: LG M2762D-PM
He tells me that he has tried the DVI conn as well as the HDMI. Same results.


Top
  Profile  
 
 Post subject: Re: HD7970 driver install problem
PostPosted: Mon Dec 24, 2012 9:02 pm 
Million Club - 20 Plus
Million Club - 20 Plus
User avatar

Joined: Sun Sep 26, 2004 9:26 am
Posts: 4739
Location: Dixon Springs, TN
Success!!!!!!!
Apparently you can't install AMD drivers when in Safe Mode. Took a fair bit of web crawling to find out that tidbit.
He also reran driver sweeper and swept one remaining nvidia video folder and all AMD/ATI video folders. Then restarted to computer. It booted into windows as normal. He then tried again to install the AMD/ATI drivers and it worked.
He is now enjoying his new HD7970.
For anyone else that comes to look at this thread the important points are:
1. run driver sweeper, even if you have used control panel to remove video drivers
2. check both nvidia and amd video drivers for removal
3. you can't install AMD/ATI drivers while in safe mode. It just ain't gonna work.


Top
  Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group