Maximum PC

It is currently Mon Apr 20, 2015 5:51 pm

All times are UTC - 8 hours

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Corrupted Xorg Module Wreaked Havok over 2 weeks.
PostPosted: Mon Jan 12, 2009 1:49 am 
Max [Ph]otographer
Max [Ph]otographer
User avatar

Joined: Mon Jun 28, 2004 4:10 pm
Posts: 5203
Hey all...

I just thought I'd post a little for-warning, Linux is not immune to driver / module corruption. :-P.

Now, how it happened I'm still not sure, this is what I know.

A) I had just completed updating my Nvidia drivers.
B) I was GPU2 folding on my main desktop (Q6600 with an 8800GTS 640MB) at the time.
C) I was attempting to play some full-screen video content when it happened.
D) It happened sort of gradually, first I got corrupted screen, then reboot, and upon attempting the video again it got progressively worse until the screen just went black seconds after login, but it didn't just blank out, it wiped down the screen in a top-to bottom over about 3-5 seconds.

I of course assumed my GPU was dead. What else would cause that? I yanked it out of the case, unscrewed the fan and shield on the HSF, blew out the dust bunnies, and attempted to spin the fan. The fan spins "weird". It's like it's got a bad bearing. But it does spin, so that was good news.

I was bummed, my Quad and it's GPU were down, so after about 4 days I attempted to start it back up. I re-attached the fan to the HS, popped it back in the machine, and booted Windows. Why Windows? Because Linux had automagic boot scripts to enable GPU2 folding on login, and I didn't want to muck with disabling those.

I was surprised when Windows booted AOK, as I was with 3DMark 06 playing for 1 minute, and then a full test. And then I folded on it, and that went OK as well. So, then I rebooted back into Linux.

Upon getting into Linux, everything "worked" ok, but there were issues. Full-screen video playback was choppy, very choppy, often causing the need for a Ctrl+Alt+Backspace. The terminal sessions were not working at all. I could not hit Ctrl+Alt+F2 and switch to a CLI, it simply bounced me back to the GUI.

I had no idea what was wrong with it, as I stated before, I had just updated the drivers.

Well, yesterday I got to playing CIV, and it played fairly well. Nothing to really complain about. And then it suddenly CTD'ed at about 1800AD (at least 100 turns into the game). From hence-forth every time I attempted to End Turn it would simply CTD, 4 times it did the same thing.

So, I got a little PO'ed, uninstalled everything that said "nvidia" in the app name, then went and updated the drivers again. Only this time there were errors. Specifically, it couldn't find the libglx.so module. Strange, I thought...

Then after googling a while I found another lost soul in the same predicament on another forum. What he found was to type "sudo dpkg -S libglx.so" and that returned "xserver-xorg-core" along with the exact location it was supposed to be installed in.

Looking at that location, I found that the NVidia installer was right! libglx.so no longer existed! So, I reinstalled the module with "sudo apt-get install --reinstall xserver-xorg-core" and it returned, and the NVidia installer went as it should. :)

Now full screen video is no longer choppy, my games no longer CTD unexpectedly, and best of all, overall performace is about 50x higher than before!

How the hell this PC was running the Nvidia driver without a glx module I haven't a clue, but I'm just glad I got the dang thing fixed! :-P


 Post subject:
PostPosted: Mon Jan 12, 2009 7:29 am 
Java Junkie
Java Junkie
User avatar

Joined: Mon Jun 14, 2004 10:23 am
Posts: 24241
Location: Granite Heaven
Wow .. thanks for the write-up, Dan-O! Interesting stuff. :)

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

© 2014 Future US, Inc. All rights reserved.