Maximum PC

It is currently Tue Jan 27, 2015 11:14 am

All times are UTC - 8 hours

Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: WD 250GB "JB" in PIO mode only..
PostPosted: Wed Jul 07, 2004 3:39 pm 

Joined: Wed Jul 07, 2004 3:24 pm
Posts: 1
Location: SE Virginia
I have an ASUS ATA266 mobo (ALiMagik chipset), and just bought a Western Digital 250GB JB hard drive. I can see the whole drive (updated BIOS & WinXP SP1 for 48 bit LBA), but I can't get the dang thing to work in DMA mode. Even Ghost (DOS mode) won't transfer faster than 120MB/min. I can't find any info on if there's a problem with this chipset and really big drives. (Previous largest was a Deskstar 60GB). Anyone know if there is a compatibility issue?

Here is what I've done so far:
- Tried 250GB drive on both Primary & Secondary IDE channels, as master & slave (even tried different 80 pin cables).

- Tried to change settings in the registry back to UDMA 5, with no result.

- Tried fix suggested on Microsoft's site: Device Manager -> shift drive to "PIO only", then back to "DMA if available".

- Installed WinXP SP2 RC2, to get the updated atapi.sys file, with no difference (later uninstalled SP2).

- Uninstalled the ALi mini IDE driver, and forced Windows default IDE driver, with no difference.

- I was running the A7A266 mobo 1013 beta 1 BIOS.. Flashed back to 1012 with no difference.

- Put the drive in manual setting in BIOS, and tried stepping setting to DMA 4/3/2/1, with no difference (not sure if ALiMagik chipset will downgrade each step automatically, or just jump straight to PIO on timeout or CRC errors).

- Returned the drive and got another one, with no difference.

Any info/ideas would be greatly appreciated!
I can't afford to upgrade further until the end of this year, so that suggestion is out. I plan on getting a 939 pin mobo when they're more plentiful & cheaper.

 Post subject:
PostPosted: Thu Jul 08, 2004 10:45 am 

Joined: Tue Jul 06, 2004 6:17 pm
Posts: 17
Make sure that the jumper on the drive is set correctly. WD drives come with Cable Select jumper enabled, which doesn't work properly 99% of the time, and I wish they'd do away with it completely.

I know you said you tried Master & Slave but sometimes people mean they just put it in the master / slave position on the IDE cable. WD Drives have no jumper installed if they're single/master, and use a jumper for master or slave.

I say this because in my excitement to install a new drive, I ran with !#@%* cable select enabled for a week before I caught it. Noob moments happen.

 Post subject:
PostPosted: Thu Jul 08, 2004 2:27 pm 
King of All Voodoo2 Cards
King of All Voodoo2 Cards
User avatar

Joined: Tue Jun 22, 2004 10:41 am
Posts: 9316
Do you have a Parallel port on your system board?

If so, is it set to ECP?

If so, change it to EPP, reboot and check to see if your drive is running in UDMA.

 Post subject:
PostPosted: Fri Jul 09, 2004 12:45 pm 
[Team Member]
[Team Member]

Joined: Sat Jun 26, 2004 4:31 am
Posts: 11125
Location: Home Sweet Home
Have you run the WD diagnostic utility on that drive yet? In the utility there is a section for setting the mode the drive runs in, see if it is set for DMA.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 8 hours

Who is online

Users browsing this forum: No registered users and 9 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

© 2014 Future US, Inc. All rights reserved.