Quantcast

Maximum PC

It is currently Sat Sep 20, 2014 11:10 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Non-working USBs after cleaning (solved)
PostPosted: Tue Jun 11, 2013 7:11 pm 
Klamath
Klamath
User avatar

Joined: Thu Dec 04, 2008 12:52 pm
Posts: 238
Hey folks,

Today, I need some help figuring out an issue I am having. I have two USB 3.0 ports in the back of my computer that will not work; however, there are two other USB 3.0 ports in the back of my computer that do work for a total of two non-working and two working USB ports. I have tried to reinstall the chipset and USB 3.0 drivers (latest versions) for my Sabertooth Z77 motherboard, uninstalled the USB host controller in device manager, and have even checked to ensure that BIOS didn't have the ports disabled.

I have used these two ports on a regular basis, but they only stopped working today after I cleaned out my PC. An interesting thing to note is that the devices I plug in receive power from the non-working ports themselves, but show no signs of trying to connect. I have tried multiple USB devices unsuccessfully in both ports to solicit a connection, no luck. USB legacy support is on. Finally, I would like to note that when I go into BIOS under boot selection, I can see my USB flash drive as an option to boot to. The USB flash drive is currently in one of the non-working USB ports.

If anyone has any suggestions or ideas, I would greatly appreciate it.

Thank you.

Solved

The issue, as I continued to research the problem, ended up being with the registry. Simply deleting a few entries and restarting the computer fixed the problem for me, and now my devices are fully connecting.

http://support.microsoft.com/kb/925196 (This is for Windows XP, but it seems to work for Windows 7. Use at your own caution.)

Please note that using system restore/image is a solution you'll want to explore first.


Top
  Profile  
 
 Post subject: Re: Non-working USBs after cleaning (solved)
PostPosted: Thu Jun 13, 2013 8:30 am 
Million Club - 20 Plus
Million Club - 20 Plus
User avatar

Joined: Sun Sep 26, 2004 9:26 am
Posts: 4739
Location: Dixon Springs, TN
Glad you were able to find a solution.
Also glad you posted it for others information.


Top
  Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group