Quantcast

Maximum PC

It is currently Wed Oct 01, 2014 4:41 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: New ATI HD7870 freezes on bootup
PostPosted: Fri Feb 15, 2013 1:32 pm 
8086
8086

Joined: Sat Nov 24, 2012 6:50 pm
Posts: 3
So I decided I needed a new graphics card since my old HD5850 just doesn't give me enough power for games. I decided to go with a gigabyte HD 7870 since it seemed like a good card. The problem is after swapping it out my computer freezes on boot. The first time I try booting it nothing happens the monitor and computer turn on but it just black screens and stays there. After powering it down and restarting it then it will display the first screen and freeze there (the screen that tells me what buttons to push to get bios or boot menu and such). At this screen it just freezes and I can't do anything, can't get into bios or boot menu. I sent it back for a replacement and the same thing happens with the new card so it has to be something else or very bad luck. If I put my old card in the computer starts fine.

windows 7-64bit OS
i7-860 cpu with a coolmaster evo cpu cooler
Intel DP55wg motherboard
coolmax NW-650B powersupply
CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory
Old graphics card is ATI HD 5850
New one that is not working gigabyte ATI HD 7870: -GV-R7870C-GD

My bios and drivers are up to date.


Top
  Profile  
 
 Post subject: Re: New ATI HD7870 freezes on bootup
PostPosted: Sat Feb 16, 2013 12:42 pm 
[Team Member]
[Team Member]

Joined: Sat Jun 26, 2004 4:31 am
Posts: 11093
Location: Home Sweet Home
Did you uninstall the old driver before removing the old card?

Did you delete the AMD videocard folder after uninstalling the video driver?

Did you run the registry section of Ccleaner to clean the registry after uninstalling the driver?

Did you cancel the popups after restarting the computer with the new card in before installing the new driver?

In all of the above you should have had the anti-virus shut off before doing anything.

Nasty


Top
  Profile  
 
 Post subject: Re: New ATI HD7870 freezes on bootup
PostPosted: Sat Feb 16, 2013 1:42 pm 
Team Member
Team Member
User avatar

Joined: Sat Apr 21, 2007 6:57 am
Posts: 1161
Do you have all the power connecters hooked up? I wonder if your PSU is on the weak side, card recommends a 500W PSU, your's is supposed to be 650W, but with some they never achieve this due to temp. constraints.


Top
  Profile  
 
 Post subject: Re: New ATI HD7870 freezes on bootup
PostPosted: Sat Feb 16, 2013 9:37 pm 
8086
8086

Joined: Sat Nov 24, 2012 6:50 pm
Posts: 3
Did all the driver removing stuff and I have all the power connecters hooked up. Still no go. I even reset my CMOS. I'm truly stumped. My roommate has a Sapphire HD 7870 card and I took it and put it in and my comp booted up with no problem. So for some reason the Gigabyte version of the card won't work on my comp and I have no clue why. I'm just giving up and sending it back. Going to try getting a Sapphire one since that seemed to work. Thanks for your help.


Top
  Profile  
 
 Post subject: Re: New ATI HD7870 freezes on bootup
PostPosted: Sun Feb 17, 2013 6:54 am 
[Team Member]
[Team Member]

Joined: Sat Jun 26, 2004 4:31 am
Posts: 11093
Location: Home Sweet Home
Keep us informed as to how the new Sapphire card worked.

Nasty


Top
  Profile  
 
 Post subject: Re: New ATI HD7870 freezes on bootup
PostPosted: Tue Feb 19, 2013 12:41 pm 
8086
8086

Joined: Sat Nov 24, 2012 6:50 pm
Posts: 3
Got a sapphire HD 7870 XT and it seems to work fine so far. Uninstalled my old card popped this baby in and the comp booted up fine. I'm not sure what it was about that gigabyte card that my computer hated but the sapphire one seems to be working.


Top
  Profile  
 
 Post subject: Re: New ATI HD7870 freezes on bootup
PostPosted: Tue Feb 19, 2013 1:47 pm 
[Team Member]
[Team Member]

Joined: Sat Jun 26, 2004 4:31 am
Posts: 11093
Location: Home Sweet Home
Did you uninstall the old driver before taking out the old card and install the new driver for the new card?

Nasty


Top
  Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

© 2014 Future US, Inc. All rights reserved.