Quantcast

Maximum PC

It is currently Sun Aug 31, 2014 12:34 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: I think I've gone slightly mad...
PostPosted: Sat Jan 05, 2013 12:16 pm 
Thoroughbred
Thoroughbred
User avatar

Joined: Fri Dec 30, 2005 5:30 pm
Posts: 1685
Location: Portland,OR
I just ordered a $450 power supply.
It's a PC Power&Cooling Turbo-Cool 1200.


(I'm upgrading from a PC Power & Cooling Silencer 750,bought in December 2006-which still works ok,even 6 1/2 years later.)

I have a new Cooler Master Storm Trooper full-tower case,which necessitated my getting the new PSU.. as I'm running out of good connections on my Silencer 750.(The power plugs are wearing out).

(2 optical drives,6 hard drives + 1 Sandisk caching SSD, EVGA GTX 480 videocard).

Should be fun..although I'm a little worried about my mom's reaction to my spending so much on a PSU.


Top
  Profile  
 
 Post subject: Re: I think I've gone slightly mad...
PostPosted: Sat Jan 05, 2013 11:38 pm 
Little Foot
Little Foot

Joined: Sat Nov 05, 2011 1:02 pm
Posts: 151
She's got every right to be pissed.....unless your running dual processors (not dual core but actually two physical processors) and Quad SLI your just ridiculous.


Top
  Profile  
 
 Post subject: Re: I think I've gone slightly mad...
PostPosted: Sun Jan 06, 2013 7:03 am 
Clawhammer
Clawhammer
User avatar

Joined: Fri Sep 23, 2005 6:22 pm
Posts: 4406
Location: In the closet
Cancel the order. You should be grounded for such irresponsibility.


Top
  Profile  
 
 Post subject: Re: I think I've gone slightly mad...
PostPosted: Sun Jan 06, 2013 2:27 pm 
Million Club - 5 Plus
Million Club - 5 Plus
User avatar

Joined: Fri Apr 25, 2008 6:35 am
Posts: 1998
AMD64Blondie wrote:
I just ordered a $450 power supply.
It's a PC Power&Cooling Turbo-Cool 1200.


gonna jump start your truck with it or something? :lol:


Top
  Profile  
 
 Post subject: Re: I think I've gone slightly mad...
PostPosted: Sun Jan 06, 2013 4:00 pm 
Thoroughbred
Thoroughbred
User avatar

Joined: Fri Dec 30, 2005 5:30 pm
Posts: 1685
Location: Portland,OR
Don't tempt me to try jump starting my mom's Subaru Forester with my new Turbo-Cool 1200..


Top
  Profile  
 
 Post subject: Re: I think I've gone slightly mad...
PostPosted: Fri Jan 11, 2013 6:08 pm 
Thoroughbred
Thoroughbred
User avatar

Joined: Fri Dec 30, 2005 5:30 pm
Posts: 1685
Location: Portland,OR
To quote Frankenstein: "IT'S ALIVE..."

New Turbo-Cool 1200 is up and working better than ever.

(So many cables... I almost didn't know what to do with them all..)

Surprisingly quiet,considering it's a 1200W power supply with a 80 mm Delta 5,000 RPM fan.


Top
  Profile  
 
 Post subject: Re: I think I've gone slightly mad...
PostPosted: Sat Jan 12, 2013 6:54 am 
Little Foot
Little Foot

Joined: Sat Dec 02, 2006 4:58 am
Posts: 107
AMD64Blondie wrote:
(I'm upgrading from a PC Power & Cooling Silencer 750,bought in December 2006-which still works ok,even 6 1/2 years later.)

PCP&C are awesome, I have a turbo-cool 500W that is 11 years old, still in use on my old recycled-parts NAS

AMD64Blondie wrote:
... I'm running out of good connections on my Silencer 750.(The power plugs are wearing out).

If you have a precision screwdriver set, or an awl / hole punch, you could use that to "re-crimp" the connectors, have had to do that several times on a few PSUs.

Dead PSUs are a good source of connectors, for the NAS above I had to use my handy Crimp tool set to add several HDD connectors (there are 12 PATA 200Gb HDDs in raidZ2 lol)


Top
  Profile  
 
 Post subject: Re: I think I've gone slightly mad...
PostPosted: Sat Jan 26, 2013 12:08 am 
Klamath
Klamath

Joined: Mon Dec 24, 2007 9:27 pm
Posts: 201
I remember the day I brought home my brand new spiffy AX1200....thought I was going too far.....but meh knowing Ive got TONS of headrooom for future upgrades is nice.....don't feel bad going to a 1,200 PSU....and honestly you made a fine choice with the PCP&C unit, I've still got a Silencer 750 in a system, just as old as yours and still working fine to this day.


Top
  Profile  
 
 Post subject: Re: I think I've gone slightly mad...
PostPosted: Sat Jan 26, 2013 5:32 am 
Clawhammer
Clawhammer
User avatar

Joined: Fri Sep 23, 2005 6:22 pm
Posts: 4406
Location: In the closet
AMD64Blondie wrote:
Surprisingly quiet,considering it's a 1200W power supply with a 80 mm Delta 5,000 RPM fan.

Impossible. Get your hearing checked, because you're going deaf!


Top
  Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group